The issues impacting Uhaul.net have been resolved and the system is now functioning again.
If you continue to experience any issues, please contact POS Support at 606901 or 1-800-223-6217, or use the live chat via the ESL life preserver icon. -------------------------------------------------------------------------------------------------
Posted Mar 24, 2026 - 11:38 MST
Monitoring
The issues impacting Uhaul.net have been resolved and the system is now functioning again.
If you continue to experience any issues, please contact POS Support at 606901 or 1-800-223-6217, or use the live chat via the ESL life preserver icon.
Posted Mar 24, 2026 - 11:26 MST
Investigating
We are currently experiencing multiple issues within Uhaul.net and are actively working to resolve them. We will provide updates as more information becomes available. For immediate assistance, please contact POS Support at 606901 or 1-800-223-6217, or use the live chat via the ESL life preserver icon.
Posted Mar 24, 2026 - 10:43 MST
This incident affected: uhaul.net (Cross Contact, Tools).