Resolved - Intermittent Reservation Creation issues in CSF

Incident Report for U-Haul System

Resolved

Users should now be able to create reservations normally.
For further assistance, please contact support at 606901 or 800-223-6217.
Posted May 18, 2026 - 16:39 MST

Update

Users should now be able to create reservations normally.
For further assistance, please contact support at 606901 or 800-223-6217.
Posted May 18, 2026 - 15:14 MST

Investigating

We are aware that some users are experiencing issues creating reservations in CSF.
Our teams are currently reviewing the issue. We will provide an update once more information is available.
Posted May 18, 2026 - 14:55 MST
This incident affected: Point of Sale (CSF (Customer Service Form)).