Timeclock Application is Back Up And Running

Incident Report for U-Haul System

Resolved

If issues continue to persist, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted May 08, 2025 - 10:29 MST

Monitoring

If issues continue to persist, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted May 08, 2025 - 10:14 MST

Investigating

Please update times manually in Workday until the issue is resolved.

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted May 08, 2025 - 09:23 MST
This incident affected: Point of Sale (POS).