Resolved - POS slowness

Incident Report for U-Haul System

Resolved

A fix has been implemented and dispatching through the POS is back up and running.

If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Mar 14, 2025 - 14:27 MST

Monitoring

A fix has been implemented and dispatching through the POS is back up and running.

If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Mar 14, 2025 - 11:28 MST

Update

To continue business operations, dispatch Using backup POS.
backuppos.uhaul.net
Centers: Login With Your SMID, Last name and entity #
Dealers: Login with your Dealer login and your Entity #

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Mar 14, 2025 - 08:52 MST

Investigating

To continue business operations, dispatch Using backup POS.
backuppos.uhaul.net
Centers: Login With Your SMID, Last name and entity #
Dealers: Login with your Dealer login and your Entity #

For further assistance, please reach out to support by calling 606901 or 800-223-6217.
-------------------------------------------------------------------------------------------------
Posted Mar 14, 2025 - 08:23 MST
This incident affected: Point of Sale (POS), uhaul.net (Cross Contact), and Rates and Distribution (Web AMT).