Offline POS Import

Incident Report for U-Haul System

Resolved

Offline POS Transactions:
If you completed transactions in Offline POS, please upload them now.
-From the Offline POS transaction page, select Receipts at the top right.
-Upload the contract from your ESL using the same method you would for BackupPOS.
-Complete the transaction in POS

Note: Offline POS Contracts must be uploaded from the same device used to create the contract. Please have these contracts uploaded prior to the end of your day.

BackupPOS Contracts:
If you completed contracts in BackupPOS, please import those contracts into POS at this time.

For further assistance, please reach out to support by calling 606901 or 800-223-6217.
-------------------------------------------------------------------------------------------------
Posted May 18, 2026 - 20:08 MST

Investigating

Offline POS Transactions:
If you completed transactions in Offline POS, please upload them now.
-From the Offline POS transaction page, select Receipts at the top right.
-Upload the contract from your ESL using the same method you would for BackupPOS.
-Complete the transaction in POS

Note: Offline POS Contracts must be uploaded from the same device used to create the contract. Please have these contracts uploaded prior to the end of your day.

BackupPOS Contracts:
If you completed contracts in BackupPOS, please import those contracts into POS at this time.

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted May 18, 2026 - 16:41 MST
This incident affected: Point of Sale (POS).