The WebBEST Physical Inventory application is now available for use again. Please proceed with completing Physical Inventory.
If you are still experiencing issues or are unable to complete Physical Inventory due to these problems, please contact inventoryvaluationprocess@uhaul.com for assistance.
Thank you for your patience. -------------------------------------------------------------------------------------------------
Posted Mar 04, 2026 - 16:50 MST
Monitoring
The WebBEST Physical Inventory application is now available for use again. Please proceed with completing Physical Inventory.
If you are still experiencing issues or are unable to complete Physical Inventory due to these problems, please contact inventoryvaluationprocess@uhaul.com for assistance.
Thank you for your patience. -------------------------------------------------------------------------------------------------
Posted Mar 04, 2026 - 16:12 MST
Update
We are currently investigating an issue affecting product inventory data. Some users are experiencing problems viewing inventory information and getting an error.
If you need assistance with inventory during this time, please reach out to the Physical Inventory Teams channel for support.
If you continue experiencing issues, you may also contact POS Support for assistance at VoIP 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Mar 04, 2026 - 13:28 MST
Investigating
We are currently investigating an issue affecting product inventory data. Some users are experiencing problems viewing inventory information and getting an error. Our team is actively working to resolve the issue and restore normal functionality swiftly. We will provide updates as more information becomes available. -------------------------------------------------------------------------------------------------