The issue causing slowness within POS has been resolved, and POS is operating normally.
Locations that were using BackupPOS may return to the normal Point of Sale. If you completed contracts in BackupPOS, please import those contracts into POS at this time
If you continue to experience slowness or need assistance, please contact Support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom-left corner of the ESL.
Posted Aug 08, 2026 - 08:50 MST
Update
The issue causing slowness within POS has been resolved, and POS is operating normally.
Locations that were using BackupPOS may return to the normal Point of Sale. If you completed contracts in BackupPOS, please import those contracts into POS at this time
If you continue to experience slowness or need assistance, please contact Support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom-left corner of the ESL.
Posted Aug 08, 2026 - 08:50 MST
Investigating
We are currently aware of an issue causing slowness within POS.
locations experiencing significant slowness may use BackupPOS to continue business operations. backuppos.uhaul.net
Centers: Login With Your SMID, Last name and entity # Dealers: Login with your Dealer login and your Entity #
We will provide additional updates as more information becomes available.
For further assistance, please reach out to Support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom-left corner of the ESL.