Wireless Authentication Issue

Incident Report for U-Haul System

Resolved

No further issues reported since change was applied. If you have further issues with WiFi, please contact network_support@uhaul.com or call 606911.
Posted Oct 21, 2025 - 08:17 MST

Monitoring

A fix has been applied to to our wireless load balancing solution and initial reports show authentications are working. We are continuing to test and validate that this issue is resolved.
Posted Oct 21, 2025 - 06:34 MST

Investigating

The Network team is currently investigating reports of wireless authentication failures. This is impacting locations company wide to connect to UHCv2.
Posted Oct 21, 2025 - 05:53 MST
This incident affected: Network (WiFi).