A fix has been implemented and receiving SMS/Email communication messages are back up and running.
If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Mar 13, 2025 - 04:13 MST
Monitoring
A fix has been implemented and receiving SMS/Email communication messages are back up and running.
If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Mar 13, 2025 - 04:06 MST
Investigating
We are experiencing issues with receiving SMS and email communication. Our team is looking into this, and updates will be posted when they are available. ------------------------------------------------------------------------------------------------
Posted Mar 12, 2025 - 14:21 MST
This incident affected: Point of Sale (POS), uhaul.com and Truck Share (Live Verification), Dealer Network (uhauldealer.com), Email/O365 applications (Email), and Workday / U-Haul life.