Resolved: Cash payments not showing in WebBEST

Incident Report for U-Haul System

Resolved

A fix has been implemented and cash transactions are now showing in WebBEST correctly.

If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.

-------------------------------------------------------------------------------------------------
Posted Mar 08, 2025 - 15:42 MST

Monitoring

A fix has been implemented and cash transactions are now showing in WebBEST correctly.

If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.

-------------------------------------------------------------------------------------------------
Posted Mar 08, 2025 - 15:12 MST

Investigating

We are currently investigating this issue.

Please take payments as debit or credit if possible to avoid potential issues at closing.

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Mar 08, 2025 - 11:41 MST
This incident affected: Point of Sale (WebBEST).