POS has been restored and is now fully operational.
Offline POS Transactions: If you completed transactions in Offline POS, please upload them now. -From the Offline POS transaction page, select Receipts at the top right. -Upload the contract from your ESL using the same method you would for BackupPOS. -Complete the transaction in POS.
BackupPOS Contracts: If you completed contracts in BackupPOS, please import those contracts into POS at this time.
The issue was caused by a backend service going down. This service supports POS, AMT, U-Box, and other applications.
BackupPOS Impact: BackupPOS was impacted separately due to Microsoft Azure issues.
For further assistance, please contact support at 606901 or 800-223-6217.
Posted May 18, 2026 - 15:00 MST
Monitoring
POS has been restored and is now fully operational.
Offline POS Transactions: If you completed transactions in Offline POS, please upload them now. -From the Offline POS transaction page, select Receipts at the top right. -Upload the contract from your ESL using the same method you would for BackupPOS. -Complete the transaction in POS.
BackupPOS Contracts: If you completed contracts in BackupPOS, please import those contracts into POS at this time.
The issue was caused by a backend service going down. This service supports POS, AMT, U-Box, and other applications.
BackupPOS Impact: BackupPOS was impacted separately due to Microsoft Azure issues.
For further assistance, please contact support at 606901 or 800-223-6217.
Posted May 18, 2026 - 14:38 MST
Update
POS has been restored and is now fully operational.
Offline POS Transactions: If you completed transactions in Offline POS, please upload them now. -From the Offline POS transaction page, select Receipts at the top right. -Upload the contract from your ESL using the same method you would for BackupPOS. -Complete the transaction in POS.
BackupPOS Contracts: If you completed contracts in BackupPOS, please import those contracts into POS at this time.
The issue was caused by a backend service going down. This service supports POS, AMT, U-Box, and other applications.
BackupPOS Impact: BackupPOS was impacted separately due to Microsoft Azure issues.
For further assistance, please contact support at 606901 or 800-223-6217.
Posted May 18, 2026 - 14:27 MST
Update
We have all hands on deck and are actively working to get these issues resolved.
BackupPOS: We're working with Microsoft on a resolution. It is currently working; However, intermittent issues may occur until the issue is fully resolved.
POS: -If you're unable to use POS; Use backupPOS. -If backupPOS is unavailable; use Offline POS.
To access Offline POS: -Sign into the Mobile POS APP. -Select Settings. -Toggle Offline POS to ON. -Select the Offline tab (at the bottom of the screen) to continue business operations.
For non-center personnel/dealers who do not have Mobile POS installed, please contact POS Support and we can provide the Apple App Store download link for Mobile POS.
For any other Offline assistance, please contact POS Support by calling ext. 606911 or 800-223-6217.
Posted May 18, 2026 - 13:02 MST
Update
Continue business operations by using Offline POS in Mobile POS App.
To access Offline POS:
Sign in to Mobile POS. Select Settings. Toggle Offline POS on. Select the Offline tab to begin dispatching and continue business operations.
For non-center personnel/dealers who do not have Mobile POS installed, please contact POS Support and we can provide the Apple App Store download link for Mobile POS.
For any other Offline assistance, please contact POS Support by calling ext. 606911 or 800-223-6217.
Posted May 18, 2026 - 11:35 MST
Update
BackupPOS is now working again and can be used to continue business operations. backuppos.uhaul.net
Centers: Login With Your SMID, Last name and entity # Dealers: Login with your Dealer login and your Entity #
Please wait until the system is fully operational before importing your backup contracts.
We have all hands on deck and are actively working to resolve this issue as quickly as possible.
For further assistance, please reach out to support by calling 606901 or 800-223-6217. -------------------------------------------------------------------------------------------------
Posted May 18, 2026 - 11:32 MST
Update
Continue business operations by using Offline POS in Mobile POS App.
To access Offline POS:
Sign in to Mobile POS. Select Settings. Toggle Offline POS on. Select the Offline tab to begin dispatching and continue business operations.
For non-center personnel/dealers who do not have Mobile POS installed, please contact POS Support and we can provide the Apple App Store download link for Mobile POS.
For any other Offline assistance, please contact POS Support by calling ext. 606911 or 800-223-6217.
Posted May 18, 2026 - 10:17 MST
Update
Continue business operations by using Offline POS in Mobile POS App.
To access Offline POS:
Sign in to Mobile POS. Select Settings. Toggle Offline POS on. Select the Offline tab to begin dispatching and continue business operations.
We will provide additional updates as more information becomes available. For any Offline assistance, please contact POS Support by calling ext. 606911 or 800-223-6217.
Posted May 18, 2026 - 09:09 MST
Investigating
We are aware of an issue causing POS and other applications to be unavailable at this time. Our teams are actively investigating and working to restore service as quickly as possible. We will provide updates as more information becomes available.
Posted May 18, 2026 - 09:00 MST
This incident affected: Point of Sale (POS), Dealer Network (uhauldealer.com), and Rates and Distribution (Web AMT).