Resolved: Endless loading on Estimated Charges page

Incident Report for U-Haul System

Resolved

Issues have cleared; Point of Sale is working properly again.

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Mar 26, 2025 - 14:53 MST

Investigating

Please restart your PC.

If issues continue to persist, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Mar 26, 2025 - 09:09 MST

Monitoring

Dispatching through the Point of Sale is working properly again.
If you experience any issues, please close your browser and reopen it.

The Dealer Network sign-in error has been resolved. You can now log in successfully and continue business operations as usual.

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Mar 26, 2025 - 07:03 MST

Investigating

We are experiencing a system outage affecting many of our critical systems. We have all hands working to get this resolved as quickly as possible.

To continue business operations, please use backupPOS - backuppos.uhaul.net

Reminder To Log-In:
Centers: Login With Your SMID, Last name and entity #
Dealers: Login with your Dealer login and your Entity #

For further assistance, please reach out to support by calling 606901 or 800-223-6217.
Posted Mar 26, 2025 - 03:15 MST
This incident affected: Point of Sale (POS).