Resolved - Unable to cover reservations
Incident Report for U-Haul System
Resolved
A fix has been implemented and AMT is able to cover reservations again.

Some reports may still be down at this time.

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Nov 12, 2024 - 07:54 MST
Monitoring
A fix has been implemented and AMT is able to cover reservations again.

Some reports may still be down at this time.

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Nov 12, 2024 - 07:42 MST
Investigating
We have all hands on deck looking into this matter.

For further assistance can contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Nov 12, 2024 - 06:28 MST
This incident affected: Rates and Distribution (Web AMT).