We are continuing to investigate an issue causing SMS and email delivery delays and failures.
Dealers who are unable to receive SMS messages may sign in directly through the POS website or Mobile POS using their Dealer Network username and password. - pos.uhaul.net
Our technical teams are actively investigating the issue and will provide additional updates as more information becomes available.
For further assistance, please reach out to Support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom-left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Aug 08, 2026 - 07:56 MST
Update
We are currently aware of an issue causing SMS and Email delivery delays and failures. This has been identified as a third-party provider issue with Twilio, impacting AT&T and Cellular One and potentially other cellular carriers. Twilio is actively investigating the issue.
Dealers please sign-in directly into POS website or Use Mobile POS - pos.uhaul.net To sign-in: Enter your Dealer Network username and Dealer Network password.
For further assistance, please reach out to Support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom-left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Aug 08, 2026 - 07:43 MST
Investigating
We are currently aware of an issue causing SMS and Email delivery delays and failures. This has been identified as a third-party provider issue with Twilio, impacting AT&T and Cellular One and potentially other cellular carriers. Twilio is actively investigating the issue.
For further assistance, please reach out to Support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom-left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Aug 08, 2026 - 07:01 MST
This incident affects: Point of Sale (POS) and uhaul.com and Truck Share (Live Verification).