HSL is Fully Restored

Incident Report for U-Haul System

Resolved

The issue was a lingering effect from the outage earlier, which impacted the network and core U-Haul Servers.

If you encounter any lingering issues, please contact support at either 606901, 800-223-6217.
-------------------------------------------------------------------------------------------------
Posted Apr 07, 2026 - 18:45 MST

Monitoring

The issue was a lingering effect from the outage earlier, which impacted the network and core U-Haul Servers.

If you encounter any lingering issues, please contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Apr 07, 2026 - 18:35 MST

Investigating

The HSL is currently unavailable. The team is actively working to resolve the issue and restore service as quickly as possible.

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. 
-------------------------------------------------------------------------------------------------
Posted Apr 07, 2026 - 18:06 MST
This incident affected: Point of Sale (Hitch Scheduling Log (HSL)).