We have verified that this issue is resolved. If you continue to have any internet or connectivity issues, please contact the Network Support team at (602)760-4923, option 6. Or Extension 606911. We can also be reached by email at network_support@uhaul.com.
Posted Apr 16, 2025 - 07:55 MST
Monitoring
Meraki has applied a fix for this issue, we are monitoring and testing to verify this has resolved the issue. These router reboots will cause connectivity failures for internet, phones, and all web applications until it is resolved.
Posted Apr 16, 2025 - 07:23 MST
Identified
Our network team have identified several field locations that appear to have internet connection issues this morning. This issue is caused by our Meraki routers rebooting on their own. Meraki support is aware of the issue and it is impacting all of their customers. We are working to find a solution as swiftly as possible but we do not have a workaround at this time. An update will be provided when we know more.
Posted Apr 16, 2025 - 05:46 MST
This incident affected: Network (Meraki (Center Networks)).