The issue causing users to be unable to dispatch has been resolved. Users can now upload contracts created in BackupPOS and continue the rental process normally.
Our teams will continue reviewing the cause of the issue.
For further assistance, please reach out to Support by calling 606901 or 800-223-6217. You can also chat with Support using the life preserver icon in the bottom-left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Sep 23, 2026 - 08:51 MST
Monitoring
The issue causing users to be unable to dispatch has been resolved. Users can now upload contracts created in BackupPOS and continue the rental process normally.
Our teams will continue reviewing the cause of the issue.
For further assistance, please reach out to Support by calling 606901 or 800-223-6217. You can also chat with Support using the life preserver icon in the bottom-left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Sep 23, 2026 - 08:40 MST
Investigating
To continue business operations, please use backupPOS - backuppos.uhaul.net
Centers: Login With Your SMID, Last name and entity # Dealers: Login with your Dealer login and your Entity #
Please do not upload Backup contracts until the system is fully operational.
For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------