POS is fully Operational

Incident Report for U-Haul System

Resolved

If issues continue to persist, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Feb 04, 2026 - 17:49 MST

Update

If issues continue to persist, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Feb 04, 2026 - 17:48 MST

Monitoring

If issues continue to persist, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Feb 04, 2026 - 17:38 MST

Update

Centers: Please close your browser, then re-open it.
Other: Please try clearing your browsing data.

Steps to clear browsing data:
- Press and hold CTRL+Shift+Delete.
- Go to the 'Advanced' tab.
- Set the time range to 'All Time.'
- Only select Browsing history, Download history, and Cached Images and files
- Click on 'Clear Data.'

If issues continue to persist, please use backupPOS to continue business operations - backuppos.uhaul.net
Centers: Login With Your SMID, Last name and entity #
Dealers: Login with your Dealer login and your Entity #

Please Do not upload BackupPOS Contracts until the System is Fully Restored.

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Feb 04, 2026 - 16:34 MST

Update

Please attempt to use backup POS. We have all hands on deck troubleshooting to get this issue resolved as soon as possible.

https://backuppos.uhaul.net/

Reminder: To Log-in
Centers: Smid, Lastname and Center #
Dealers: Username and Dealer #
----------------------------------------
If you run into an issue when trying to access backuppos.uhaul.net please try clearing your browser data and then try again
Steps to clear browsing data:

Centers: Please close your browser, then re-open it.

Dealers/ everyone else:
- Press and hold CTRL+Shift+Delete.
- Go to the 'Advanced' tab.
- Set the time range to 'All Time.'
- Select Browsing history, Download history, Cookies and Other Site Data, and Cached Images and files
- Click on 'Clear Data.'

Please do not upload BackupPOS Contracts until the System is Fully Restored.
----------------------------------------
If you are still running into an issue trying to use backuppos.uhaul.net at a center, please place the center uScan in airplane mode and utilize the offline pos option in the POS mobile App.
-------------------------------------------------------------------------------------------------
Posted Feb 04, 2026 - 15:38 MST

Update

We are continuing to investigate this issue.
Posted Feb 04, 2026 - 15:38 MST

Update

Please attempt to use backup POS. We have all hands on deck troubleshooting to get this issue resolved as soon as possible.

https://backuppos.uhaul.net/

Reminder: To Log-in
Centers: Smid, Lastname and Center #
Dealers: Username and Dealer #
----------------------------------------
If you run into an issue when trying to access backuppos.uhaul.net please try clearing your browser data and then try again
Steps to clear browsing data:

Centers: Please close your browser, then re-open it.

Dealers/ everyone else:
- Press and hold CTRL+Shift+Delete.
- Go to the 'Advanced' tab.
- Set the time range to 'All Time.'
- Select Browsing history, Download history, Cookies and Other Site Data, and Cached Images and files
- Click on 'Clear Data.'

Please do not upload BackupPOS Contracts until the System is Fully Restored.
----------------------------------------
If you are still running into an issue trying to use backuppos.uhaul.net at a center, please place the center uScan in airplane mode and utilize the offline pos option in the POS mobile App.
-------------------------------------------------------------------------------------------------
Posted Feb 04, 2026 - 15:36 MST

Investigating

Continue with sales transaction in WebBEST:

WebBEST > Sale Items > Sales Items

If the sales type or payment method is not supported in WebBEST, use Backup POS
https://backuppos.uhaul.net/

Reminder: To Log-in
Centers: Smid, Lastname and Center #
Dealers: Username and Dealer #

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Feb 04, 2026 - 14:44 MST
This incident affected: Point of Sale (POS, Showroom Sales), uhaul.net (Cross Contact), and Rates and Distribution (Web AMT).