Uhaul.net Intermittent Issues resolved

Incident Report for U-Haul System

Resolved

If issues continue to persist, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Feb 05, 2026 - 10:49 MST

Investigating

Our teams are actively researching the issue with loading the Menu Items in Uhaul.net.

We will continue to post updates as we get more information.

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Feb 05, 2026 - 08:46 MST
This incident affected: uhaul.net (Reports, Tools).