AMT Slowness Resolved

Incident Report for U-Haul System

Resolved

The slowness impacting AMT has been resolved.

All systems should now be operating normally. If you continue to experience any issues, please contact POS Support at VOIP extension 606901, call 1-800-223-6217, or use the live chat via the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Mar 24, 2026 - 11:41 MST

Monitoring

The slowness impacting AMT has been resolved.

All systems should now be operating normally. If you continue to experience any issues, please contact POS Support at VOIP extension 606901, call 1-800-223-6217, or use the live chat via the life preserver icon in the bottom left corner of the ESL.
Posted Mar 24, 2026 - 11:30 MST

Update

If you are experiencing an issue, please close the browser and open a new session, switching Browsers, or Clear browser Cache.

Steps to clear browsing data:
- Press and hold CTRL+Shift+Delete.
- Go to the 'Advanced' tab.
- Set the time range to 'All Time.'
- Only select Browsing history, Download history, and Cached Images and files
- Click on 'Clear Data.'

If you're needing assistance, don't hesitate to seek assistance from our support team. You can contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
Posted Mar 24, 2026 - 11:20 MST

Investigating

We have all hands on deck looking into this matter.

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Mar 24, 2026 - 11:03 MST
This incident affected: Rates and Distribution (Web AMT).