Timeclock not updating times in Workday

Incident Report for U-Haul System

Resolved

This issue has been resolved and the HR developers will be working with payroll to resolve any time events that were missed during this incident.
Posted Apr 02, 2025 - 13:07 MST

Identified

The HR development team have identified an issue with the Timeclock application not properly updating times in Workday when an employee clocks in or out. When the issue has been resolved, an update will be provided.
Posted Apr 02, 2025 - 12:06 MST
This incident affected: Time clock.