Equipment is updating on the ESL

Incident Report for U-Haul System

Resolved

Refresh the page, the equipment should update on the ESL.

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Jun 12, 2025 - 11:53 MST

Monitoring

Refresh the page, the equipment should update on the ESL.

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Jun 12, 2025 - 11:43 MST

Investigating

Our team is working to get the equipment updating.

For further assistance, please reach out to support by calling 606901 or 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL.
-------------------------------------------------------------------------------------------------
Posted Jun 12, 2025 - 11:25 MST
This incident affected: Point of Sale (ESL (Electronic Scheduling Log)).