There was a service outage with Workday; this affected multiple businesses, including U-Haul. Workday is back online.
If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted May 04, 2026 - 14:39 MST
Update
There was a service outage with Workday; this affected multiple businesses, including U-Haul. Workday is back online.
If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted May 04, 2026 - 14:24 MST
Monitoring
There was a service outage with Workday; this affected multiple businesses, including U-Haul. Workday is back online.
If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted May 04, 2026 - 14:24 MST
Investigating
The Workday Site is currently down due to an issue on the web provider's end. We will update you when we have further details.