Resolved: Multiple U-Haul Applications Down

Incident Report for U-Haul System

Resolved

Access to the sites and applications are back up and running.

If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.
------------------------------------------------------------------------------------------------
Posted Feb 05, 2025 - 15:32 MST

Monitoring

Access to the sites and applications are back up and running.

If you encounter any lingering issues, feel free to contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL.
------------------------------------------------------------------------------------------------
Posted Feb 05, 2025 - 15:19 MST

Investigating

To continue business operations, please use backupPOS - backuppos.uhaul.net

Reminder To Log-In:

Centers: Login With Your SMID, Last name and entity #
Dealers: Login with your Dealer login and your Entity #

For further assistance, please reach out to support by calling 606901 or 800-223-6217.
-------------------------------------------------------------------------------------------------
Posted Feb 05, 2025 - 14:08 MST
This incident affected: Point of Sale (POS), uhaul.com and Truck Share (uhaul.com), and uhaul.net (Tools).