If you encounter any lingering issues, please contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL --------------------------------------------------------------------------------------------------
Posted Jul 16, 2025 - 09:51 MST
Monitoring
If you encounter any lingering issues, please contact support at either 606901, 800-223-6217, or initiate a chat by clicking on the life preserver icon in the bottom left corner of the ESL --------------------------------------------------------------------------------------------------
Posted Jul 16, 2025 - 09:22 MST
Investigating
We are currently investigating the issue. We will post updates as they are available.
For further assistance please contact support at VOIP extension 606901, call us at 800-223-6217. You can also chat in using the life preserver icon in the bottom left corner of the ESL. -------------------------------------------------------------------------------------------------
Posted Jul 16, 2025 - 07:52 MST
This incident affected: Point of Sale (Hitch Scheduling Log (HSL)).