Intermittent Workday Access Issues

Incident Report for U-Haul System

Resolved

This incident has been resolved.
Posted May 04, 2026 - 21:07 MST

Investigating

The Workday Site is currently experiencing intermittent access issues on the web provider's end. We will update you when we have further details.
--------------------------------------------------------------------------------------------------
Posted May 04, 2026 - 15:00 MST
This incident affected: Workday / U-Haul life.